OpenSubsystems

Business Components for Java Applications

Documentation

Database Setup

Additional Resources

Last modified

$Author: bastafidli $
$Date: 2006/08/27 07:52:11 $
$Revision: 1.12 $
$RCSfile: dbsetup.html,v $

This document will help you to get started with each database management systems supported by OpenSubsystems. It will walk you through obtaining, installing and configuring the database so that OpenSubsystems can access it and use it as its persistence store.

IBM DB2

Official page | Download | Documentation | Fix Packs | JDBC
Tested version: IBM DB2 Universal Database Personal Developer's Edition, Version 8.2.2 Fixpak 3 (8.1 Fixpak 10) with DB2 Universal JDBC type 4

Download the installation package from the DB2 download page. The downloaded database comes with a free development license. Extract the content of the downloaded package and start the installation by launching setup.exe. Follow the easy to use installation wizard to install the database on your system. We recommend to perform custom installation and select all the unchecked components to make sure all the necessary functionality is available. When asked to configure the DB2 Administration Server choose to use the Local System account.

After the installation of DB2 is finished, it is recommended to install the latest fixpak to address any functional and security issues, which were already corrected. Download the latest fixpak, for example file FP10_WR21362_PE.exe, extract it's content and start the installation by launching setup.exe. Follow the easy to use installation wizard to install the fixpak on your system.

DB2 8.1.x database needs C compiler to compile stored procedures. You do not need this compiler if you are using DB2 version 8.2 or higher. If there is no C compiler installed on your system, you can use Microsoft Visual C++ Toolkit 2003, which is a free compiler from Microsoft. Download and execute VCToolkitSetup1.0.1.exe to start the installation. Follow the easy to use installation wizard and install the compiler to directory c:\msvc. Once the installation is complete, continue with the setup of your environment.

  1. Close all applications related to DB2 and stop the DB2 server. To stop the server you can for example type and execute the db2stop command from the Command Window, which can be accessed from the Start menu by opening IBM DB2 and then Command Line Tools folder.
  2. Set up enviroment variables, for example using System applet in Control Panel folder
    • Add compiler lib path c:\msvc\lib to the LIB variable
    • Add compiler include path c:\msvc\include to the INCLUDE variable
    • Add path to the compiler directory c:\msvc\ to the PATH variable
  3. Set up DB2 registry by starting the Configuration Assistant from the Start menu by opening IBM DB2 and then Set-up Tools folder. From the Configure menu select the DB2 Registry item.
    • Add registry

      DB2_SQLROUTINE_COMPILE_COMMAND = cl -Od -W2 /TC -D_X86_=1 -I%DB2PATH%\include SQLROUTINE_FILENAME.c /link -dll -def:SQLROUTINE_FILENAME.def / out:SQLROUTINE_FILENAME.dll %DB2PATH%\lib\db2api.lib

    • Add registry

      DB2_SQLROUTINE_COMPILER_PATH = c:\msvc\vcvars32.bat

  4. Start the DB2 server (type and execute the db2start command).

After the installation is finished, it is necessary to create a database. Start the Control Center, which can be found in the IBM DB2, General Administration Tools group in the Start menu. In the tree on the left right click on the All Databases node and from the context menu select Create Database and Standard... item. (We were not able to use With Automatic Maintenance... menu option due to files missing in the installation image. The response from IBM was "In order to be able to use Automatic Maintenance, you must configure it prior to using it. The errors you are getting are an indication that the automatic maintenance was not configured. Here is a link with more explanation on the automatic maintenance."). Enter "OSS" as database name and alias and confirm the dialog by clicking the Finish button. Database OSS will be added to the tree.

After the database is created, it is necessary to create a user tablespace and system temporary tablespace with bigger page size than the default one. Start the Control Center, which can be found in the IBM DB2, General Administration Tools group in the Start menu. In the tree on the left expand All Databases node and there expand node of the database you have created in previous step. Right click on the Table Spaces node and from the context menu select Create... item. Enter "OSSTABLESPACE" as table space name. Click Next button to continue to the next dialog. Specify Regular type of table space. Go to the next dialog by pressing Next button. Click Create button to create new buffer pool with bigger page size. In new opened dialog enter Buffer pool name "OSSBUFFPOOL", from the drop down menu select Page size 32 and confirm the dialog with OK button. Specified buffer pool is visible within the list on the dialog. Choose this created buffer pool and click Next to continue. On the next dialog choose System-managed space (low maintenance) and click the button Next to continue. On the last dialog specify container for tablespace. Click Add button and select directory the container will be created in. Into field File name enter name of the container, eg. osscontainer001. Finally click the Finish button to create new user table space.

After user table space was created it is necessary to create also system temporary tablespace. Right click on the Table Spaces node and from the context menu select Create... item. Enter "OSSTEMPTABLESPACE" as table space name. Click Next button to continue to the next dialog. Specify System temporary type of the table space. Go to the next dialog by pressing Next button. Choose OSSBUFFERPOOL buffer pool from the list and click Next to continue. On the next dialog choose System-managed space (low maintenance) and click Next to continue. On the last dialog specify container for tablespace. Click Add button and select directory the container will be created in. Into field File name enter the name of the container, eg. osstempcontainer001. Finally click the Finish button to create new system temporary table space.

Under certain circumstances (e.g. inserts of many records) the database transaction log can become full and error will occur. The transaction log can be increased when you right click on a database name under the All Databases node and from the context menu select the Configure Parameters... menu item.

  • Changing LOGFILSIZ allows to specify bigger logfiles
  • Changing LOGPRIMARY and/or LOGSECOND allows to specify more logfiles

DB2 requires that the user, which is used to connect to a database must be an operating system user. In Windows you can create user from the User Accounts applet in the Control Panel. Create users with names basta, bastatest and bastatest1 with password fidli. Create another user named db2admin with password password. Once the db2admin user is created you must add it to the database, for example using the Control Center application, which can be found in the IBM DB2, General Administration Tools group in the Start menu. In the tree on the left side expand nodes All Databases, OSS, User and Group objects until you see the node DB Users. Right click on the DB Users node and from the context menu select the Add... menu item. From the user dropdown select user db2admin and check all the options below.

To use DB2 with OpenSubsystems you have to include a DB2 JDBC driver on the classpath so that OpenSubsystems can access it. DB2 comes with several JDBC drivers, but from the version 8.2 the only non deprecated one is the DB2 Universal JDBC driver, which can act as both type 2 and type 4 (pure java) driver. We recommend to use this driver as type 4 driver. For the type 4 driver you need to include files db2jcc.jar and db2jcc_license_cu.jar on a classpath. To connect to the database using type 4 connection you have to include server name and port in the connection url. Example of the type 4 url is

jdbc:db2://localhost:50000/OSS

If you wish to connect to a database using type 2 connection it is important to set up PATH environment variable, for example using the System applet in the Control Panel. Modify PATH variable to add path to the 'SQLLIB\BIN\' subdirectory in the DB2 installation directory (for example: C:\Program Files\IBM\SQLLIB\BIN\). Also modify the command starting your java application by adding java library path command line option -Djava.library.path pointing to the DB2 driver as well as to the file db2jdbc.dll, for example

-Djava.library.path=C:\Progra~1\IBM\SQLLIB\java\;C:\Progra~1\IBM\SQLLIB\BIN\

To connect to the database using type 2 connection you should not include server name and port in the connection url. Example of the type 2 url is

jdbc:db2:OSS

Once you run OpenSubsystems with DB2 and decide to remove all the created content from the database, the easiest way to do it is from the Control Center application. Under the node for your database click on the Tables node and delete all the tables within schema of the same name as the users you have created earlier. Repeat the same for Views and Stored Procedures (found under Application Objects) nodes. Finally repeat the same for Schemas. You may receive error regarding existing sequences. Drop the sequences manually using your favorite SQL tool before deleting the Schemas.

HSQLDB

Official page | Download | Documentation
Tested version: HSQLDB 1.8.0.1

HSQLDB is open source SQL relational database engine written in Java. The tested version, which also includes JDBC driver is packaged with OpenSubsystems and can be found in the external\hsqldb directory. There is no need to perform any installation or configuration, the only requirement is to have hsqldb.jar on a classpath so that OpenSubsystems can access it. The default build configuration bundles HSQLDB with OpenSubsystems applications so that they can be used out of the box without a need to have any database installed.

HSQLDB stores its data in files created in a directory set in the configuration file at the end of the following line

oss.datasource.url=jdbc:hsqldb:...

Once you run OpenSubsystems with HSQLDB and decide to remove all the created content from the database, the easiest way to do it is to remove the entire directory mentioned above. Next time you run OpenSubsystems, HSQLDB will recreate this directory and its database files.

MaxDB

Official page | Download | Documentation
Tested version: MaxDB 7.6.0.12 with JDBC driver 7.6.0.12 Build 4339

MaxDB is commercial grade database originally developed by SAP AG. SAP released its own database SAP DB for SAP/R3 as an open source project. From version 7.5 SAP DB was rebranded as MaxDB, the license was changed to dual GPL/commercial license and it is now jointly developed by MySQL AB and SAP AG.

Since MaxDB is a newer version of SAP DB they share some of its subsystems. If you want to have installed both of these databases on your system at the same time, install SAP DB first and only then continue with installation of MaxDB. Only one version of SQL Studio can be installed at any given time, but the SQL Studio, which comes with MaxDB can be use to access your SAP DB database. There is no need to install the SQL Studio shipped with SAP DB. If you have it already instaled you will be asked to uninstall it before the newer version of MaxDB SQL Studio can be installed.

Download file maxdb-all-win-32bit-i386-7_6_00_12.zip and extract it's content. This file contains the MaxDB database server and many command line utilities. To start installation, execute file SDBSETUP.exe, select option to start installation and follow the easy to use wizard to install MaxDB on your system. After the installation is finished, reboot the computer before proceeding any further.

Download two additional files, maxdb-dbmgui-setup-7_6_00_12.exe, which is MaxDB Database Manager and maxdb-sqlstudio-setup-7_6_00_12.exe, which is SQL Studio and execute them to install GUI utilities that help with administration and maintenance of MaxDB.

After the installation is finished, it is necessary to create a database. Launch the Database Manager from MySQL MaxDB folder. Click on the Create... link to start the database creation. The first data value you have to enter is the database name. To allow both SAP DB and MaxDB exist on your system at the same time, you have to use different database names for each of them. Enter "OSSMAX" for MaxDB and proceed to the Create Database Instance page. Make sure a correct database version is selected since if SAP DB and MaxDB are installed at the same time, both will appear in this list. Proceed to the Adjust Parameters page accepting the default values along the way. On the Adjust Parameters page click on the Extended text and change the "SESSION_TIMEOUT" parameter to 0. Proceed to the Volumes page and once there add one data volume and one log volume large enough for testing. For example, make the data volume size 1GB and the log volume size 150MB. Finish the wizard by accepting default values until database instance installation starts. In case you receive an error message after the installation is done and there is no database visible in the Database Manager, go to the Instance menu, Add... menu item and click the Add button. Database instance OSSMAX will be added to the list.

When OSSMAX database instance appears in the top list, click on the Configuration tab on the left to adjust it's settings. For development purposes, it is recommended to enable the Log overwriting option. This can be done by clicking on the Log Settings option and selecting option "Overwrite Mode for the Log Area" in the Configuration Wizard. MaxDB is now ready to be used with OpenSubsystems.

To use MaxDB with OpenSubsystems you have to include MaxDB JDBC driver on the classpath so that OpenSubsystems can access it. The tested version of this JDBC driver is included with OpenSubsystems and can be found in the external\maxdb directory.

Once you run OpenSubsystems with MaxDB and decide to remove all the created content from the database, the easiest way to do it is from the SQL Studio found in MySQL MaxDB folder. Login to the server localhost and database OSSMAX as user DBADMIN with password secret. In the tree on the left side expand node Owned Users and delete all items other than DBSERVICE.

MS SQL Server

Official page | Download | Documentation | All versions
Default version: MS SQL Server 2005 Express Edition Service Pack 1 with Advanced Services with jTDS 1.2

MS SQL Server 2005 Express Edition is the free, easy-to-use, lightweight version of SQL Server 2005. SQL Server Express is free to use and redistribute and therefore may represent an ideal database management system for Microsoft platform.

Download and install MS SQL Server 2005 Express Edition database. We recommend to download and install the Express Edition with Advanced Services since it includes additional features such as SQL Server Management Studio Express allowing you to manage your server and it also includes Service Pack 1. Extract the content of downloaded SQLEXPR_ADV.EXE file and start the installation by launching autorun.exe. We recommend to perform custom installation and select all the unchecked components to make sure that all the necessary functionality is available. When asked to configure services accounts choose to use the Local System account. Choose mixed mode (Windows Authentification and SQL Server Authentication) as an authentication mode. You can find the default administration password expected by OpenSubsystems here.

After the software is installed, it is necessary to create a database. Start the SQL Server Management Studio Express, which can be found in the Microsoft SQL Server 2005 group in the Start menu. In the tree on the left side expand nodes localhost (if your server runs on your local computer, otherwise expand the node corresponging to your server name) until you see node Databases. Right click on the Databases node and from the context menu select New Database... Enter database name "OSS" and confirm the dialog. Database OSS will be added to the tree.

To use MS SQL Server with OpenSubsystems you have to include a JDBC driver supporting this database on the classpath so that OpenSubsystems can access it. We recommend to use open source jTDS JDBC driver, which is included with OpenSubsystems and can be found in the external\jtds directory. This driver provides excellent performance and stability. Microsoft also provides it own SQL Server 2005 Driver for JDBC, which is type 4 JDBC driver available from the download section of the MS SQL Server website.

The JDBC driver uses TCP/IP protocol to connect to the the database. This protocol is by default disabled after the installation. You have to enable this protocol so that OpenSubsystems can access your database. Start the SQL Server Configuration Manager, which can be found in the Configuration Tools subfolder of Microsoft SQL Server 2005 group in the Start menu. Expand nodes SQL Server Configuration Manager, SQL Server 2005 Network Configuration until you see node Protocols for SQLEXPRESS. Click on this node to display list of protocols on the right. Right click on the TCP/IP protocol and from the context menu select Enable. To make the connection unambiguous you may also need to right click again on the TCP/IP protocol and from the context menu select item Properties. There on the IP Addresses tab under section IPAll clear out the value for TCP Dynamic Ports and enter value for port in the TCP Port field. The default value for port should be 1433 and you can confirm it here. Once you close the dialog you will have to restart the server for this setting to take affect. Click on the SQL Server 2005 Services to display the list of the services. Right click on the SQL Server (SQLEXPRESS) item and from the context menu select Restart.

Important sideline, if you will want to connect from the SQL Server Management Studio Express using TCP/IP and you have explictly specified the port, you will have to specify the server name in form ip_address,port or hostname,port.

Once you run OpenSubsystems with MS SQL Server and decide to remove all the created content from the database, the easiest way to do it is from the SQL Server Management Studio Express application. Under the node for your database click on the Tables node and delete all tables owned by user OpenSubsystems is using to connect to the database. You can find the default user name here. The dialog allows you to continue in deletion even if you receive an error so continue clicking OK until all tables in the tree are removed. Repeat the same for Views and Stored Procedures nodes. Next delete entries with specified user name in Users and Schemas under Security node of your database. For each deleted user you also have to delete it's login under the global Security, Logins node.

MySQL

Official page | Download | Documentation
Tested version: MySQL 4.1.14 with Connector/J 3.1.10

MySQL is one of the most popular open source SQL databases used by many open source projects (the M in LAMP) and commercial clients.

Download the installation package from the MySQL download page and follow the easy to use installation wizard to install the database on your system. Select installation suitable for a development machine and OLTP database processing and do not forget to select support for InnoDB tables (tables with transactional support). In addition to MySQL database server, it is recommended to also install MySQL Administrator and MySQL Query Browser utilities that help with administration and maintenance of MySQL.

After the installation is finished, it is necessary to create a database. The easiest way to do it is to launch MySQL Administrator, in the list on the left side click on the Catalogs item. In the list of Schematas below right click and select Create New Schema menu item. Enter schema name "OSS" and confirm the dialog. Database schema OSS will be added to the list.

To use MySQL with OpenSubsystems you have to include MySQL JDBC driver called Connector/J on the classpath so that OpenSubsystems can access it. The tested version of this JDBC driver is included with OpenSubsystems and can be found in the external\mysql directory.

Once you run OpenSubsystems with MySQL and decide to remove all created content from the database, the easiest way to do it is from the MySQL Administrator found in the MySQL folder in the Start menu. Login to the server localhost and database OSS as user root with password password. In the list on the left side click on the User Administration item. In the list of User Accounts below delete all the items other than root. Then click on the Catalogs item in the left list. In the list of Schematas below right click on the schema "OSS" and select the Drop Schema menu item from the context menu. Confirm the confirmation dialogs until the schema is dropped. You will have to recreate the "OSS" schema using the process described earlier to be able to run OpenSubsystems again.

PostgreSQL

Official page | Download | Documentation
Tested version: PostgreSQL 8.0.3 with JDBC 3 driver 8.0 Build 312

PostgreSQL is one of the most popular open source SQL databases used by many open source projects and commercial clients.

Download the installation package from the PostgreSQL download page and follow the easy to use installation wizard to install the database on your system. Version 8.x supports and can be installed on MS Windows operating system directly (previous versions have to be installed using CygWin).

After the installation is finished, it is necessary to create a database. Start the pgAdmin III application, which can be found in the PostgreSQL group in the Start menu. In the tree on the left side expand nodes Servers, PostgreSQL Database Server 8.0 until you see the node Databases. Right click on the Databases node and from the context menu select the New Database menu item. Enter name "OSS" and confirm the dialog. Database OSS will be added to the tree.

To use PostgreSQL with OpenSubsystems you have to include PostgreSQL JDBC driver on the classpath so that OpenSubsystems can access it. The tested version of this JDBC driver is included with OpenSubsystems and can be found in the external\postgresql directory.

Once you run OpenSubsystems with PostgreSQL and decide to remove all created content from the database, the easiest way to do it is from the pgAdmin III application found in the PostgreSQL folder. In the tree on the left side expand nodes Servers, PostgreSQL Database Server 8.0 and Users. From the list of users delete all items other than user 'postgres'. Now in the tree on the left side expand nodes Servers, PostgreSQL Database Server 8.0, Databases, OSS and Schemas. From the menu Tools select item Query tool and in the newly opened pgAdmin III Query window type and execute following command 'drop schema xyz cascade', where xyz is name of every item under Schemas node other than schema 'public'.

Oracle

Official page | Download | Documentation | JDBC
Tested version: Oracle9i 9.2.0.1.0 Enterprise Edition with 10.2.0.1.0 JDBC driver

Download the installation packages from the Oracle download page. The downloaded database comes with free development license. Extract the content of downloaded packages and start the installation by launching setup.exe. Follow the easy to use installation wizard to install the database on your system. We recommend to use the Enterprise Edition and General Purpose configuration for your testing. When you are during installation asked to enter Global Database Name and SID enter "OSS".

We have encountered some issues when using Oracle JDBC drivers versions 9.x, therefore we recommend to use the latest Oracle JDBC thin driver for Oracle 10g, which is backward compactible with Oracle 9i. Once you download file ojdbc14.jar, include it on a classpath so that OpenSubsystems can access it. It is critical to make sure that the ojdbc14.jar is the first file on the classpath to avoid any hard to solve compatibility issues. During development this can be for example done by going to Order and Export tab in the project properties in Eclipse and moving the newly added ojdbc14.jar to the front of all jars file immediately after the JRE entry.

Once you run OpenSubsystems with Oracle and decide to remove all the created content from the database, the easiest way to do it is from the Enterprise Manager Console found in the Oracle folder. Login to the OSS database by expanding nodes Network and Databases in the tree on the left. Further expand nodes Security and Users and delete all the items with text TEST in their name.

SAP DB

Official page | Download | Documentation
Tested version: SAP DB 7.4.3.32 with JDBC driver 7.4.4 Build 003-000-002-514

SAP DB is commercial grade database developed by SAP AG. SAP released its own database for SAP/R3 as an open source project. From version 7.5 SAP DB was rebranded as MaxDB, the license was changed to dual GPL/commercial license and it is now developed by MySQL AB. The last SAP DB version released under LGPL license that allows it's commercial use without any strings attached is version 7.4.3.32.

Download file sapdb-all-win-32bit-i386-7_4_3_32.zip and extract it's content. This file contains the SAP DB database server and many command line utilities. To start installation, execute file SDBINST.exe from the command line, select option 9 and accept all the default options by pressing ENTER and "y" key. After the installation is finished, reboot the computer before proceeding any further.

Download two additional files, dbmgui74-setup.exe, which is Database Manager Second Edition and sqlstudio74-setup.exe, which is SQL Studio and execute them to install GUI utilities that help with administration and maintenance of SAP DB.

After the installation is finished, it is necessary to create a database. Launch the Database Manager Second Edition from SAP DB folder. Click on the Installation Wizard link to start the database creation. The first data value you have to enter is the database name. To allow both SAP DB and MaxDB exist on your system at the same time, you have to use different database names for each of them. Enter "OSS" for SAP DB and proceed to the Create Database Instance page. Make sure a correct database version is selected since if SAP DB and MaxDB are installed at the same time, both will appear in this list. Proceed to the Adjust Parameters page accepting the default values along the way. On the Adjust Parameters page click on the Extended text and change the "SESSION_TIMEOUT" parameter to 0. Proceed to the Volumes page and once there add one data volume and one log volume large enough for testing. For example, make the data volume size 1GB and the log volume size 150MB. Finish the wizard by accepting default values until database instance installation starts. In case you receive an error message after the installation is done and there is no database visible in the Database Manager Second Edition, go to the Instance menu, Register Instance item and click the Add Server button. Database instance OSS will be added to the list.

When OSS database instance appears in the top list, click on the Configuration tab on the left to adjust it's settings. For development purposes, it is recommended to enable the Log overwriting option. This can be done by clicking on the Log Settings option and selecting option "Overwrite Mode for the Log Area" in the Configuration Wizard. SAP DB is now ready to be used with OpenSubsystems.

To use SAP DB with OpenSubsystems you have to include SAP DB JDBC driver on the classpath so that OpenSubsystems can access it. The tested version of this JDBC driver is included with OpenSubsystems and can be found in the external\sapdb directory.

Once you run OpenSubsystems with SAP DB and decide to remove all the created content from the database, the easiest way to do it is from the SQL Studio found in SAP DB folder. Login to the server localhost and database OSS as user DBA with password DBA. In the tree on the left side expand node Owned Users and delete all items other than DOMAIN and SYS.

Sybase Adaptive Server Enterprise

Official page | Download | Documentation | FAQ
Tested version: Sybase Adaptive Server Enterprise Suite 12.5.2 GA with jTDS 1.1

Download and install Sybase Adaptive Server Enterprise 12.5.2 Developer's Edition. The downloaded database comes with free development license. Extract the content of downloaded ase1252_de_win.zip file and start the installation by launching setup.exe. We recommend to perform full installation to make sure all the components are available. During the installation notice port number where the ASE servers will be configured on. By default these are ports 5000 for Adaptive Server, 5001 for Backup Server, 5002 for Monitor Server, 5003 for XP Server and Web Services are on port 8181 for HTTP and 8187 for HTTPS.

After installing DBS and rebooting your machine it is neccessary to create a database. First you need to start the database engine since it is not started by default. You can do it from the Windows Control Panel Services applet by starting all 4 Sybase services. The other option is to use Server Config application in Sybase folder and select Adaptive Server from the left panel and then clicking Configure Adaptive Server.

Once the database engine is started, launch Sybase Central Java Edition application in the Sybase group in the Start menu. Go to the Tools menu and select menu item Connect... Change the user name to "sa" and leave the password empty. Once connected, expand the folders in the left panel and click on the Database Devices node. In the right panel double click Add Database Device. Type device path such as c:\sybase\data\oss.dat and name of the device such as oss. Select the size of the device to be large enough for testing, for example 1 GB.

Click on the Databases node and in the right panel double click Add Database. Type OSS as the name of the database. On the device information page click the Add button and select device oss for data and specify size large enough to hold data, for example 800MB. Click the Add button once more and select device oss for transaction log and specify size large enough to hold log, for example 200MB. On the Default Location Information page specify with override since the data and transaction log are on the same device. Aften summary page confirm the dialog to create the database.

You need to adjust the options for the created database to allow OpenSubsystems to run properly. Right click on the OSS database and choose the Properties item from the context menu. New window will be open. Go to the Options tab and check "abort tran on log full", "ddl in tran" items and "trunc log on chkpt". Confirm the changes and close the dialog with OK button. Using the same steps set the these options for tempdb database. You can find it under Temporary Databases List View node. More info about these options is available at:

http://manuals.sybase.com/onlinebooks/group-as/asg1250e/refman/@Generic__BookTextView/94897

To use Sybase ASE with OpenSubsystems you have to include a JDBC driver supporting this database on the classpath so that OpenSubsystems can access it. We recommend to use open source jTDS JDBC driver, which is included with OpenSubsystems and can be found in the external\jtds directory. This driver produces consistent, deterministic and error free behaviour regardless of connection pool used unlike the jConnect drivers.

Sybase ASE is shipped with two versions of jConnect JDBC driver, version 5.5 and version 6.0. These drivers are located in the jConnect-X_X subdirectories of the installation directory. You need to include on the classpath both jar files located in the classes subdirectory of jConnect-X_X directory if you decide to use this driver.

When you are testing OpenSubsystems with Sybase, periodically execute command "dump tran OSS with no_log" using you favorite SQL tool connected to Sybase ASE server to prevent log getting too full. Development version of Sybase ASE allows only 5 concurrent connections and therefore it is important to disconnect from the database when running connection pool tests. In case of any problems, it is recommended to check the Sybase log file, which is stored in C:\Sybase\ASE-12_5\install directory assuming C:\Sybase is the directory where you installed Sybase ASE.

Once you run OpenSubsystems with Sybase ASE and you decide that you want to remove all created content from the database, the easiest way to do it is from the Sybase Central Java Edition application. Under the node for your database click on the User Tables node and delete all created tables. If you receive error message, just accept it, refresh the view by hitting F5 key and delete the remaining tables. Repeat the same for Views and Stored Procedures nodes and delete also all items other than dbo under Users. For each deleted user you also have to delete it's login under Logins node.